Cforce RF Red control cable issues

General discussion
Post Reply
Posts: 1
Joined: Mon Oct 29, 2018 6:44 am

Tested my Red control cable yesterday and could not get it to work. Tried two separate cforce mini RF motors, with both sxu-1 and wcu-4, on two separate DSMC2 bodies and had the same issue. As soon as I select Red control protocol in the menu, connection is lost between cforce rf and hand unit, and will not re-link unless control port cable is removed or deactivated.
Hendrik Voss
Posts: 14
Joined: Mon Nov 30, 2015 6:29 pm

Sorry for the issues. We found a software glitch in cforce mini RF that can cause this behaviour. We will release a fix soon!

Posts: 6
Joined: Tue Dec 25, 2018 12:16 pm

You could try the Fischer 3 pin cable if you have the Box or some other module with a fischer port.

Sarkari Result Pnr Status
Posts: 3
Joined: Fri Jul 03, 2020 8:56 pm

I’m running into the exact same thing. I swear it used to work. Haven’t had a RED job in a long time (yay!) and just recently updated all of my Arri gear. My RF Motor connected through the CTRL port will lose connection and then regain it the second I pull that Lemo. Everything works just fine with the AMC-1 through the SYNC port. Tried another CTRL cable with the same loss of connection result.

Just had a chance to run a test with a Komodo equipped with both the 9 Pin EXT and 00B Lemo CTRL. RF motor with the CTRL cable has the connection problem as soon as the cable is plugged into the body. The same RF motor running the 9 Pin cable works perfectly.

Has the most recent update in the RF motor reintroduced the bug from 2019?
Posts: 11
Joined: Mon Jan 30, 2023 12:36 pm


this problem should be fixed with SUP 1.2.19 for cforce mini RF.
When you experience this bug with a newer version please contact us directly at with exact setup and SW details.

all the best
ECS Service Team
Post Reply